Home Forums Kamanja Forums Data Science & Models Failed to add a scala model

This topic contains 2 replies, has 2 voices, and was last updated by  Archived_User57 1 year, 8 months ago.

  • Author
    Posts
  • #13150 Reply

    Archived_User57
    Participant

    Using kamanja RC1 and starting with an empty metadat store, i could run the hello world scala sample with the following steps (after uploading EngineConfig.json of course)
    – Upload Compile Config (option 40), and selecting input/SampleApplications/metadata/config/Model_Config._HelloWorld.json
    – Add Message (option 10), and selecting input/SampleApplications/metadata/message/Message_Definition_HelloWorld.json
    – Add Model – Scala (option 3), and selecting input/SampleApplications/metadata/model/HelloWorld.scala
    then pushing the input and watching the output

    i tried to run my own sample which is actually based on the hello world sample with only slight changes. i tried to run using the same above steps. uploading the config and adding the message were successful, but adding the model failed with what looks like dependency erros. here is one of the errors:

    /opt/KAMANJA/workingdir/testthemodel/testthemodel.scala:4: error: object FatafatBase is not a member of package com.ligadata
    import com.ligadata.FatafatBase._
    ^

    Is there something missing in the steps? or is there something wrong in my sample files?

    in the attach you can find all the error messages i got, along with the new model files (model config, msg def and scala model)

    appreciate the help

  • #13154 Reply

    Archived_User36
    Participant

    Hello,

    change com.ligadata.FatafatBase to com.ligadata.KamanjaBase and try again.
    i believe the JAR file name was changed in RC1

    Regards,
    Haitham

  • #13155 Reply

    Archived_User57
    Participant

    Thank you Haitham,
    looks like i used the old model.
    Marked complete by Donald

Reply To: Failed to add a scala model
Your information: