Home Forums Kamanja Forums Problems & Solutions Installation error

This topic contains 1 reply, has 2 voices, and was last updated by  William 1 year, 3 months ago.

  • Author
    Posts
  • #19749 Reply

    JP Creedon
    Member

    From comments:

    I got ERROR message when I tried to install Kamanja on VMvare virtual machine with OS system as the following:

    ==> Downloading http://mirrors.ibiblio.org/apache/kafka/0.10.0.0/kafka-0.10.0.0-src.tgz
    ######################################################################## 100.0%
    ==> gradle
    Last 15 lines from /Users/LCR/Library/Logs/Homebrew/kafka/01.gradle:
    > Could not resolve all dependencies for configuration ‘:classpath’.
       > Could not resolve com.github.ben-manes:gradle-versions-plugin:0.12.0.
         Required by:
             org.apache.kafka:kafka-0.10.0.0-src:0.10.0.0
          > Could not resolve com.github.ben-manes:gradle-versions-plugin:0.12.0.
             > Could not get resource ‘https://jcenter.bintray.com/com/github/ben-manes/gradle-versions-plugin/0.12.0/gradle-versions-plugin-0.12.0.pom‘.
                > Could not GET ‘https://jcenter.bintray.com/com/github/ben-manes/gradle-versions-plugin/0.12.0/gradle-versions-plugin-0.12.0.pom‘.
                   > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    * Try:
    Run with –stacktrace option to get the stack trace. Run with –info or –debug option to get more log output.

    BUILD FAILED

    Could you help me with that?

    Thank you SO much!

  • #19757 Reply

    William
    Keymaster

    It looks like when kafka is building, the build tool it uses, gradle, is attempting to download resources required to build and is failing to download some POM file because it is unable to communicate with the URL. The line

    GET ‘https://jcenter.bintray.com/com/github/ben-manes/gradle-versions-plugin/0.12.0/gradle-versions-plugin-0.12.0.pom‘.

    indicates that that specific pom file is inaccessible. When I run that now, however, I am able to retrieve that file. I would try building kafka again and see if it can find it now.

     

Reply To: Installation error
Your information: