Home Forums Kamanja Forums Data Science & Models issues developing Java models

This topic contains 4 replies, has 3 voices, and was last updated by  Archived_User1 1 year, 6 months ago.

  • Author
    Posts
  • #13212 Reply

    Archived_User28
    Participant

    Hello all,

    after finishing a Java model i built it and got the following 2 errors seen in the screenshot.
    Please note that i was able to run the model in Kamanja successfully without fixing these errors.

    is there a workaround to be able to build the models successfully in IDEs ?

    P.S : code is attached too, just remove “.txt” extension.

    Regards,
    Haitham

    • This topic was modified 1 year, 6 months ago by  Archived_User28.
    • This topic was modified 1 year, 5 months ago by  JP Creedon.
  • #13216 Reply

    Archived_User28
    Participant

    any thoughts or updates on this issue ?

    Regards,
    Haitham

  • #13218 Reply

    Archived_User79
    Participant

    There will be some missing libraries (jars) .. just make sure you have these jars as dependencies in your IDE in order to compile the model ..


    Ibrahim Salem
    Project Manager, ligaDATA

    email : ibr…@ligadata.com
    skype: ibrahimsalem75
    mobile: +926 795930013

    Home

  • #13219 Reply

    Archived_User28
    Participant

    i already added all the jars, i think the problem is scala/java compatibility inside IDEs.

    Regards,
    Haitham

  • #13222 Reply

    Archived_User1
    Participant

    Hi Haitham,

    Can you add the jar scala-library-2.10.4.jar from <KamanjaInstall>/lib/system/ to your project?

Reply To: issues developing Java models
Your information: