Home Forums Kamanja Forums Data Science & Models Java/Scala Model Runtime error

This topic contains 1 reply, has 2 voices, and was last updated by  Archived_User28 1 year, 8 months ago.

  • Author
    Posts
  • #13079 Reply

    Archived_User36
    Participant

    Hello all,
    im developing a new java/Scala example using the new API.
    i wrote CompileConfig.json, MessageDef.json and Model.scala files , and made the following steps:

    1) add compileconfig [40]
    2) add message [10]
    3) add model – scala [3]
    4) exit [51]
    5) push messages to kafka
    .. but when i start the engine [StartEngine.sh] i get the following error :

    KamanjaManager is running now. Waiting for user to terminate with CTRL + CERROR [pool-7-thread-4] – Failed to execute message. Reason:null Message:Not found Message Type “1”
    ERROR [pool-7-thread-3] – Failed to execute message. Reason:null Message:Not found Message Type “12”
    ERROR [pool-7-thread-3] – Failed to execute message. Reason:null Message:Not found Message Type “55”
    ERROR [pool-7-thread-1] – Failed to execute message. Reason:null Message:Not found Message Type “”id””
    ERROR [pool-7-thread-4] – Failed to execute message. Reason:null Message:Not found Message Type “2”
    ERROR [pool-7-thread-1] – Failed to execute message. Reason:null Message:Not found Message Type “”id””
    ERROR [pool-7-thread-3] – Failed to execute message. Reason:null Message:Not found Message Type “56”
    ERROR [pool-7-thread-3] – Failed to execute message. Reason:null Message:Not found Message Type “106”
    ERROR [pool-7-thread-4] – Failed to execute message. Reason:null Message:Not found Message Type “3”
    ERROR [pool-7-thread-4] – Failed to execute message. Reason:null Message:Not found Message Type “4”
    ERROR [pool-7-thread-3] – Failed to execute message. Reason:null Message:Not found Message Type “272”

    and it kept going on.
    im thinking it has something to do with the MessageDeff or the Data.
    is there any rules to define and write these files ? anyone else has an idea where the problem might be?

    Regards,
    Haitham

  • #13080 Reply

    Archived_User28
    Participant

    Hi Haitham ,

    did you add System.<msg_name> at the first of each row in the csv file ? , if no please do and tell what u get .

    Thanks
    Saleh

Reply To: Java/Scala Model Runtime error
Your information: