Home Forums Kamanja Forums Features & Releases Kamanja 1.1 installation – replacing newer version of git?

This topic contains 4 replies, has 2 voices, and was last updated by  Archived_User13 1 year, 6 months ago.

  • Author
    Posts
  • #13337 Reply

    Archived_User13
    Participant

    Before Installing Kamanja, I upgraded my git to 2.5 (from 1.7.1) and it looks like this installation set that back and that version doesn’t let me sync with github projects. I am not 100% sure, but only thing I did after I setup system and make sure I could clone and build Kamana is to install Kamanja 1.1 using brew. If this is true, it should be fixed. I have VM snapshot before Kamanja installation through brew and I could rerun the steps, but I want to bring this as possible issue (not sure what other software that installation step is replacing with older versions).

    Thanks

  • #13338 Reply

    Archived_User28
    Participant

    Brew installation of pre-packaged binaries and git upgrades and management of a separate repository seem to be unrelated items to me. Even if brew did have anything to do with this, it doesn’t have anything to do with what we are doing to install and would be outside our scope to fix. All the brew formula does is download the package, untar and copy into brew’s install dir. Nothing that involves git. Offhand I’d guess there is simply an issue with the git upgrade.

    Best to try to reproduce the symptoms. Can you post any errors you’re seeing so I know what to expect?

  • #13339 Reply

    Archived_User28
    Participant

    As an additional thought, brew does have some dependencies on git. Perhaps some links were corrupted when you upgraded. Further investigation required.

    • #13340 Reply

      Archived_User13
      Participant

      I reverted to my previous snapshot and make sure git is working for me and take snapshot with any other updates. I will go to through installation steps and post again the result.

      thanks

      • #13341 Reply

        Archived_User13
        Participant

        I verified accessing git (as well as java – using 1.8) after going through brew installation and it seems to be oK. So it is non-issue for now – not sure what happened in previous installation step.

Reply To: Kamanja 1.1 installation – replacing newer version of git?
Your information: