Home Forums Kamanja Forums Data Science & Models Kamanja-1.2.2 : Running HelloWorld PMML Model

This topic contains 5 replies, has 2 voices, and was last updated by  Archived_User1 1 year, 8 months ago.

  • Author
    Posts
  • #13490 Reply

    Archived_User28
    Participant

    Hello,

    i installed Kamanja-1.2.2 on a single node VM ,and was able to get the engine running.
    after running HelloWorldApp.sh successfully , i pushed some sample data (PushSampleDataToKafka_HelloWorld.sh) also successfully.

    issue : when i started the engine ( kamanja start -v) it failed with the below error. looks like it couldnt read the messages.
    Any idea on what might be the issue?

    FYI: i tried the same steps but for the HelloWorld.scala model and was able to run it and get the correct output.

    ERROR [pool-8-thread-4] - Model Failed => System.HelloWorld. Reason: null. Message: scala.Predef$.ArrowAssoc(Ljava/lang/Object;)Ljava/lang/Object;
    ERROR [pool-8-thread-4] - StackTrace:java.lang.NoSuchMethodError: scala.Predef$.ArrowAssoc(Ljava/lang/Object;)Ljava/lang/Object;
    	at System.HelloWorld.initialize(HelloWorld.scala:93)
    	at System.HelloWorld.execute(HelloWorld.scala:145)
    	at com.ligadata.KamanjaManager.LearningEngine$$anonfun$RunAllModels$5.apply(LearningEngine.scala:160)
    	at com.ligadata.KamanjaManager.LearningEngine$$anonfun$RunAllModels$5.apply(LearningEngine.scala:146)
    	at scala.collection.IndexedSeqOptimized$class.foreach(IndexedSeqOptimized.scala:33)
    	at scala.collection.mutable.ArrayOps$ofRef.foreach(ArrayOps.scala:108)
    	at com.ligadata.KamanjaManager.LearningEngine.RunAllModels(LearningEngine.scala:146)
    	at com.ligadata.KamanjaManager.LearningEngine.execute(LearningEngine.scala:247)
    	at com.ligadata.KamanjaManager.ExecContextImpl$$anonfun$execute$1.apply(ExecContext.scala:84)
    	at com.ligadata.KamanjaManager.ExecContextImpl$$anonfun$execute$1.apply(ExecContext.scala:82)
    	at scala.collection.IndexedSeqOptimized$class.foreach(IndexedSeqOptimized.scala:33)
    	at scala.collection.mutable.ArrayOps$ofRef.foreach(ArrayOps.scala:108)
    	at com.ligadata.KamanjaManager.ExecContextImpl.execute(ExecContext.scala:82)
    	at com.ligadata.InputAdapters.KafkaSimpleConsumer$$anonfun$StartProcessing$3$$anon$1$$anonfun$run$1$$anonfun$apply$1.apply$mcV$sp(KafkaSimpleConsumer.scala:288)
    	at scala.util.control.Breaks.breakable(Breaks.scala:37)
    	at com.ligadata.InputAdapters.KafkaSimpleConsumer$$anonfun$StartProcessing$3$$anon$1$$anonfun$run$1.apply(KafkaSimpleConsumer.scala:264)
    	at com.ligadata.InputAdapters.KafkaSimpleConsumer$$anonfun$StartProcessing$3$$anon$1$$anonfun$run$1.apply(KafkaSimpleConsumer.scala:260)
    	at scala.collection.Iterator$class.foreach(Iterator.scala:727)
    	at kafka.utils.IteratorTemplate.foreach(IteratorTemplate.scala:32)
    	at scala.collection.IterableLike$class.foreach(IterableLike.scala:72)
    	at kafka.message.MessageSet.foreach(MessageSet.scala:67)
    	at com.ligadata.InputAdapters.KafkaSimpleConsumer$$anonfun$StartProcessing$3$$anon$1.run(KafkaSimpleConsumer.scala:260)
    	at scala.actors.threadpool.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1060)
    	at scala.actors.threadpool.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:574)
    	at java.lang.Thread.run(Thread.java:745)
  • #13491 Reply

    Archived_User1
    Participant

    I haven’t been able to reproduce this. If you remove the scala model and add the PMML model is the error still present?

    Please send me your MetadataAPIConfig.properties, Engine1Config.properties and ClusterConfig.json files so I can take a look and try to reproduce again.

  • #13492 Reply

    Archived_User28
    Participant

    here are the files.
    also i tried to remove the scala model and add the PMML model, still the same issue.

  • #13493 Reply

    Archived_User1
    Participant

    What is your operating system?

    What version of java do you have (and is it oracle Jdk or openJdk)?

    What version of scala do you have?

    I’ll start looking into this soon.

  • #13494 Reply

    Archived_User28
    Participant

    – the system : Windows 8.1 , running a Centos6.7 VM

    – for scala : scala -version gives :
    Scala code runner version 2.11.7 — Copyright 2002-2013, LAMP/EPFL

    – for java : i used this file “jdk-8u65-linux-x64.tar.gz” , from this link http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
    (as suggested by the documentation)
    …… and java -version gives :
    java version “1.8.0_65”
    Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

  • #13495 Reply

    Archived_User1
    Participant

    I believe Kamanja 1.2.2 still requires scala 2.10.4. Support for 2.11.7 won’t be available until the 1.3 release. I suspect there may be an issue there as sbt will likely be compiling as 2.10. However, since you’re scala home points to a 2.11 version of scala, there is likely a mismatch between the PMML being compiled and the jars being included as part of the class path.

    I’ll use scala 2.11.7 on 1.2.2 to see if that helps me reproduce the issue.

Reply To: Kamanja-1.2.2 : Running HelloWorld PMML Model
Your information: