Home Forums Kamanja Forums Features & Releases Kamanja 1.5 Released!

This topic contains 13 replies, has 3 voices, and was last updated by  Stuart Schmukler 1 year, 4 months ago.

  • Author
    Posts
  • #19341 Reply

    JP Creedon
    Member

    Hello everyone!

    Happy National Swimming Pool Day! It is our pleasure to announce the release of Kamanja 1.5!

    Please find the release notes: http://kamanja.org/kamanja-release-1-5-rel-notes/

    Some highlights:

    • Kafka Kerberos and SSL
    • H2D2 Support
    • Support for Multiple Storage Adapters
    • Message Definition Generator

    Thanks!

  • #19349 Reply

    Dhaval Kolapkar

    The new kafka versions when downloaded from homebrew do not have .sh extensions for their scripts while those from the kafka binaries have. This is an inconsistency which is affecting kamanja scripts WatchQueues and CreateQueues and similar related to kafka queues. Solution is to rename the scripts with a .sh extension.

    Error:

    /usr/local/Cellar/kamanja/1.5.0/bin/WatchOutputQueue.sh: line 6: /usr/local/Cellar/kafka/0.10.0.0/bin/kafka-console-consumer.sh: No such file or directory

    E.g.:

    mv /usr/local/Cellar/kafka/0.10.0.0/bin/kafka-console-consumer /usr/local/Cellar/kafka/0.10.0.0/bin/kafka-console-consumer.sh

  • #19381 Reply

    Stuart Schmukler

    Folks

    I have a problem with the installation on my Mac.  There seems to be a bad formula in ‘kamanja.rb’

    Here is the transcript:

    ===

    $  sudo rm -r $(brew –cache)

    Password:

    rm: /Users/sasconsul/Library/Caches/Homebrew: No such file or directory

    $  brew untap ligadata-kamanja/tap

    Error: No available tap ligadata-kamanja/tap.

    $  brew tap ligadata/tap

    ==> Tapping ligadata/tap

    Cloning into ‘/usr/local/Library/Taps/ligadata/homebrew-tap’…

    remote: Counting objects: 3, done.

    remote: Compressing objects: 100% (2/2), done.

    remote: Total 3 (delta 0), reused 2 (delta 0), pack-reused 0

    Unpacking objects: 100% (3/3), done.

    Checking connectivity… done.

    Aborting the installation. Please install scala 2.10 or 2.11.

    Error: Invalid formula: /usr/local/Library/Taps/ligadata/homebrew-tap/kamanja.rb

    exit

    Error: Cannot tap ligadata/tap: invalid syntax in tap!

    $

    ===

     

    Hope you can help,

    Stuart

  • #19382 Reply

    JP Creedon
    Member

    Hi Stuart,

    There is a line in the log :

    Aborting the installation. Please install scala 2.10 or 2.11.

    This indicates that scala us either not installed or the existing installation can’t be found. We check for scala by checking 2 things, we check if the environmental variable $SCALA_HOME is set or if the command ‘which scala’ returns a valid scala executable.

    Try either setting $SCALA_HOME

    export SCALA_HOME=/path/to/scala/install

    Or adding your scala installation to the path

    export PATH=/path/to/scala/install/bin:$PATH

    Regards.

  • #19384 Reply

    Dhaval Kolapkar

    Could you also update homebrew before tapping or untapping it. Also, please let us know if you still face the issue after setting SCALA_HOME and updating homebrew. I am hoping you are following the steps given in the kamanja.org. Please let us know if you still face the same issue.

    • #19385 Reply

      JP Creedon
      Member

      Also try the following path for export

      export SCALA_HOME=/usr/local

      • #19386 Reply

        Stuart Schmukler
        Participant

        None of the steps have helped.   I have been following the steps on kamanja.org.

        I have:

        • updated brew
        • scala 2.11.2 installed
        • tried setting SCALA_HOME to /usr/local and /usr/local/scala

        Currently, I am following the steps ‘brew doctor’ has suggested to clean-up my brew house 🙂

        How can I step trough the tap?

  • #19388 Reply

    Stuart Schmukler
    Participant

    Folks,

    Fixed a number of problems that ‘brew doctor’ pointed out. [Did not help.]

    Hacked the scala script to figure out where $SCALA_HOME should be pointing, also did not help:

    export SCALA_HOME=/usr/local/Cellar/scala/2.11.2/libexec

  • #19395 Reply

    Dhaval Kolapkar

    Could you run the following commands and let me know:

    scala -version

    java -version

    echo $SCALA_HOME

    echo $JAVA_HOME

    which scala

    which java

     

     

    • #19405 Reply

      Stuart Schmukler
      Participant

       

      The only thing I can think of is that I am running yosemite.

      Here is what my system reports:

      $ scala -version

      Scala code runner version 2.11.2 — Copyright 2002-2013, LAMP/EPFL

      /usr/local/Cellar/scala/2.11.2/libexec

      $

      $  java -version

      java version “1.8.0_74”

      Java(TM) SE Runtime Environment (build 1.8.0_74-b02)

      Java HotSpot(TM) 64-Bit Server VM (build 25.74-b02, mixed mode)

      $

      $  echo $SCALA_HOME

      /usr/local/Cellar/scala/2.11.2/libexec

      $

      $  echo $JAVA_HOME

      /Library/Java/JavaVirtualMachines/jdk1.8.0_74.jdk/Contents/Home

      $

      $  which scala

      /usr/local/bin/scala

      $  which java

      /Library/Java/JavaVirtualMachines/jdk1.8.0_74.jdk/Contents/Home/bin/java

       

  • #19396 Reply

    Dhaval Kolapkar

    I used the following steps on a new mac and it worked:

    1.

    ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)”

    2.

    ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

    3.

    brew update

    4.

    rm -r $(brew –cache)

    5.

    brew untap ligadata-kamanja/tap

    brew tap ligadata/tap

    6.

    brew info kamanja

    brew install kamanja

     

  • #19409 Reply

    Dhaval Kolapkar

    Shouldnt be an issue. It seems you have used homebrew to install Scala. However, Scala is installed at /usr/local/Cellar/scala/2.11.8/

    Could you try reinstalling scala and checking the location. It should not be at libexec

  • #19412 Reply

    Stuart Schmukler
    Participant

    Reinstalling scala from brew did the trick.  I set scala home:

     

    SCALA_HOME=/usr/local/opt/scala/idea

    Thank-you,

    Stuart

Reply To: Kamanja 1.5 Released!
Your information: