Home Forums Kamanja Forums Data Science & Models Kamanja model dependency issues

This topic contains 2 replies, has 3 voices, and was last updated by  Archived_User79 1 year, 8 months ago.

  • Author
    Posts
  • #13479 Reply

    Archived_User57
    Participant

    Hi,

    I am trying to use a java model, which is dependent on a jar say, X.jar. But, the “add model” step fails while instantiating the ModelInstanceFactory, with a message that – class say, Y could not be found. The class Y however is in jar X.jar.

    I’ve added X.jar in the CLASSPATH in MetadataAPIConfig.properties. And have also added the dependency in Model_Config.json as –

    {
    
        "HelloWorldModel": {
    
            "Dependencies": [
    
                "kamanjabase_2.10-1.0.jar","X.jar"
    
            ],
    
            "MessageAndContainers": [
    
                "com.ligadata.kamanja.samples.messages.msg1"
    
            ]
    
        }
    
    } 

    I’m using Kamanja-1.2, and the setup is on Mac. Please help in resolving this.

    Thanks,

    Bijeet

  • #13480 Reply

    Archived_User1
    Participant

    Hi,

    We’ll look into it and keep you posted.

    Thanks,
    Samer

  • #13481 Reply

    Archived_User79
    Participant

    Hi Bijeet ,

    This was an open issue in github https://github.com/ligaDATA/Kamanja/pull/822 and it solved in the next release
    I am not able to reproduce it with the latest release .

    Thanks,
    Ahmed

Reply To: Kamanja model dependency issues
Your information: