Home Forums Kamanja Forums Problems & Solutions Not able to start kamanjaS

This topic contains 1 reply, has 1 voice, and was last updated by  William Tarver 6 months ago.

  • Author
    Posts
  • #27392 Reply

    Saurabh

    I’m trying to run kamanja using the following command

    bash $KAMANJA_HOME/bin/kamanja start -v

    and getting the following error:

    Using the default file, /usr/local/kamanja/config/Engine1Config.properties
    ERROR [main] – The File  ($KAMANJA_HOME/config/library_list) is not found:
    ERROR [main] – Failed to load configuration
    java.lang.Exception: Possible deployment error: The file $KAMANJA_HOME/config/library_list that lists the default libraries is not found
    at com.ligadata.MetadataAPI.ConfigUtils$.readMetadataAPIConfigFromPropertiesFile(ConfigUtils.scala:1790) [KamanjaInternalDeps_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.MetadataAPI.MetadataAPIImpl$.readMetadataAPIConfigFromPropertiesFile(MetadataAPIImpl.scala:4236) [KamanjaInternalDeps_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.MetadataAPI.MetadataAPIImpl$.InitMdMgrFromBootStrap(MetadataAPIImpl.scala:4295) [KamanjaInternalDeps_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.KamanjaManager.KamanjaMetadata$.InitBootstrap(KamanjaMetadata.scala:1009) [kamanjamanager_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.KamanjaManager.KamanjaManager.initialize(KamanjaManager.scala:684) [kamanjamanager_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.KamanjaManager.KamanjaManager.com$ligadata$KamanjaManager$KamanjaManager$$run(KamanjaManager.scala:922) [kamanjamanager_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.KamanjaManager.KamanjaManager$.main(KamanjaManager.scala:1456) [kamanjamanager_2.11-1.6.2.jar:1.6.2]
    at com.ligadata.KamanjaManager.KamanjaManager.main(KamanjaManager.scala) [kamanjamanager_2.11-1.6.2.jar:1.6.2]

    This file ($KAMANJA_HOME/config/library_list) is present on the location.

    I even changed the permission t0 777, but still not able to get kamanja up

  • #27395 Reply

    William Tarver

    Hi Saurabh,

    Your error is somewhat odd to me. I can only reproduce this if I intentionally move the file out of the config directory AND if I run a MetadataAPI command. If I run “bash $KAMANJA_HOME/bin/kamanja start -v” it starts fine for me. It doesn’t even look for the library_list file since the files contained in library_list are kept internally in KamanjaManager and don’t require the file to start.

    If I intentionally reproduce the error with a MetadataAPI command, which stems from a different library as the “kamanja start” command, I run the following command to reproduce:

    bash $KAMANJA_HOME/bin/kamanja upload cluster config $KAMANJA_HOME/config/ClusterConfig_kafka_v10.json

    I see the error as such:

    Using default configuration /private/tmp/Kamanja/Kamanja-1.6.2_2.11/config/MetadataAPIConfig.properties

    ERROR [main] – The File  (/private/tmp/Kamanja/Kamanja-1.6.2_2.11/config/library_list) is not found:

    ERROR [main] – Failed to load configuration

    java.lang.Exception: Possible deployment error: The file /private/tmp/Kamanja/Kamanja-1.6.2_2.11/config/library_list that lists the default libraries is not found

     

    Please note that when it lists the library_list file, it does NOT mention $KAMANJA_HOME explicitly. In fact, no repro steps I’ve taken have managed to produce the exact string $KAMANJA_HOME as part of the error. It always breaks it down to my actual install location, which in this case is /private/tmp/Kamanja/Kamanja-1.6.2_2.11.

     

    So, a couple questions:

    1. Did you see this error when attempting to add any metadata?

    2. Did you at any time install or run kamanja as sudo? Even if you changed file permissions this is relevant.

    3. Does this issue occur in a different install location such as under your $HOME directory?

    4. Can you edit the file $KAMANJA_HOME/config/log4j2.xml where you see:

    <Root level=”WARN”>

    <AppenderRef ref=”CONSOLE” />

    <AppenderRef ref=”HourlyRoll” />

    </Root>

    Please change to:

    <Root level=”DEBUG”>

    <AppenderRef ref=”CONSOLE” />

    <AppenderRef ref=”HourlyRoll” />

    </Root>

    to place logging in debug mode and reproduce the issue. Then paste the contents of $KAMANJA_HOME/logs/KamanjaLog.log in a reply.

Reply To: Not able to start kamanjaS
Your information: